本文作者:心月

ThinkPHP5框架的安装配置方法和过程

心月IT博客 2019-02-14
摘要:ThinkPHP5的环境要求如下:<

ThinkPHP5的环境要求如下:

  • ThinkPHP5.0:PHP >= 5.4.0 (ThinkPHP5.1: PHP>=5.6.0)

  • PDO PHP Extension

  • CURL PHP Extension

严格来说,ThinkPHP无需安装过程,这里所说的安装其实就是把ThinkPHP框架放入WEB运行环境(前提是你的WEB运行环境已经OK),可以通过两种方式获取和安装ThinkPHP。

一、下载ThinkPHP安装

获取ThinkPHP的方式很多,官方网站(http://thinkphp.cn)是最好的下载和文档获取来源。

官网提供了稳定版本的下载:http://thinkphp.cn/down/framework.html

由于ThinkPHP5.0还在测试阶段,所以需要通过Git服务器下载,Git服务地址:https://github.com/top-think/think

下载或者使用GIT克隆到本地后,请(解压缩后)放置于你的WEB根目录下面的tp5子目录。

二、使用Composer安装

ThinkPHP支持使用Composer安装,如果还没有安装 Composer,你可以按 Composer安装 中的方法安装。在 Linux 和 Mac OS X 中可以运行如下命令:

curl -sS https://getcomposer.org/installer | php
mv composer.phar /usr/local/bin/composer

在 Windows 中,你需要下载并运行 Composer-Setup.exe

如果遇到任何问题或者想更深入地学习 Composer,请参考 Composer 文档(英文)Composer 中文

如果你已经安装有 Composer 请确保使用的是最新版本,你可以用 composer self-update 命令更新 Composer 为最新版本。

然后在命令行下面,切换到你的web根目录下面并执行下面的命令:

composer create-project topthink/think tp5 dev-master --prefer-dist

由于目前尚未正式发布,所以先用dev-master分支。

如果出现错误提示,请根据提示操作或者参考Composer中文文档

如果国内访问composer的速度比较慢,可以参考这里的说明使用国内镜像

无论你采用什么方式获取的ThinkPHP框架,现在只需要做最后一步来验证是否正常运行。

在浏览器中输入地址:

http://localhost/tp5/public/

如果浏览器输出如图所示:
thinkPHP5框架的安装配置方法和过程

恭喜你,现在已经完成ThinkPHP的安装!

如果你无法正常运行并显示ThinkPHP的欢迎页面,那么请参考下面的列表检查下你的服务器环境:

  • ThinkPHP5.0是PHP5.4以上版本(ThinkPHP5.1是PHP5.6以上版本)(注意:PHP5.4dev版本和PHP6均不支持

  • WEB服务器是否正常启动

 

文章版权及转载声明:

作者:心月 本文地址:http://www.xinyueseo.com/thinkphp/81.html发布于 2019-09-07
文章转载或复制请以超链接形式并注明出处心月IT博客

分享到:
赞(

发表评论

快捷输入:

    评论列表 (有 0 条评论,人围观)参与讨论